1.      Enter global configuration mode.

 

 

router> enable

router# config t

 

2.      Configure hostname and passwords. (You've got this box, give it a name to help you manage it. Also, you must secure the powerful privileged EXEC with an enable password and enable secret password.)

 

 

router(config)#hostname Lab-B

Lab-B(config)#enable secret class

Lab-B(config)#enable password cisco

 

6.      Configure the line con 0 and line vty 0 4 (the telnet login). (This is another step to secure this router before you open it up to the world, and it will allow you to telnet in after you leave the site where it's installed.)

 

 

Lab-B(config)#line con 0

Lab-B(config-line)#login

Lab-B(config-line)#password cisco

Lab-B(config)#line aux 0

Lab-B(config-line)#login

Lab-B(config-line)#password cisco

Lab-B(config-line)#line vty 0 4

Lab-B(config-line)#login

Lab-B(config-line)#password cisco

Lab-B(config-line)#exit

Lab-B(config)#exit

Lab-B#

 

3.     Configure the interfaces. (Before you can let this router do its job, you must configure the interfaces. This will allow your router interfaces to make their layer 2 and 3 connections to remote locations. Also note that it is good that you configured security before you turn these interfaces on!)

 

Lab-B(config)#int fa0/0

Lab-B(config-if)#ip address 219.17.100.1 255.255.255.0

Lab-B(config-if)#no shutdown

Lab-B(config)#int s0/0

Lab-B(config-if)#ip address 199.6.13.1 255.255.255.0

Lab-B(config-if)#clock rate 56000

Lab-B(config-if)#bandwidth 56

Lab-B(config-if)#no shutdown

Lab-B(config)#int s0/1

Lab-B(config-if)#ip address 201.100.11.2 255.255.255.0

Lab-B(config-if)#no shutdown

Lab-B(config-if)#exit

 

4.      Configure the routing protocol and table. (Now it's time to get down to business, and let this router do its job. The job of ROUTING routed protocols like IP and IPX.)

 

 

 

Lab-B(config)#router rip

Lab-B(config-router)#network 219.17.100.0

Lab-B(config-router)#network 199.6.13.0

Lab-B(config-router)#network 201.100.11.0

Lab-B(config-router)#exit

 

5.      Configure the ip host table (which defines the router name to address translation). (This step allows you to easily make connections to remote routers by hostname, instead of IP address. It is also a good step in verifying which routers belong to which IP addresses.)

 

 

Lab-B(config)#ip host Lab-A 192.5.5.1 205.7.5.1 201.100.11.1

Lab-B(config)#ip host Lab-B 219.17.100.1 199.6.13.1 201.100.11.2

Lab-B(config)#ip host Lab-C 223.8.151.1 204.204.7.1 199.6.13.2

Lab-B(config)#ip host Lab-D 210.93.105.1 204.204.7.2

Lab-B(config)#ip host Lab-E 210.93.105.2

 

 

7.      Save the running configuration to NVRAM. (You should probably do this after each step, by hitting Ctrl-Z and then copy run start!)

 

 

Lab-B#copy run start

 

 

Optional commands:

 

no ip domain-lookup

 

Disables DNS lookup entered in global configuration mode (Prevents the annoying lookup for mis-typed commands)

description Connected to LAN B

 

Provides a description to an interface entered in interface configuration mode.

ip http server

Enable browser management entered in global configuration mode

no ip classless

Disable classless IP routing entered in global configuration mode